» » Mozilla Firefox: проблема с несовместимыми расширениями
  • Автор: Nata
  • (голосов: 1)

Mozilla Firefox: проблема с несовместимыми расширениями

1976 0 25-07-2017, 12:28
Наверное, самой главной причиной современной популярности браузера Firefox, считается возможность увеличения функциональных способностей при помощи расширений. Таким образом, при их применении, Mozilla Firefox превращается в настоящий комбайн, который разрешает не лишь путешествовать по просторам сети-Интернет, но и, конечно, делает ненужным применением многочисленных сторонних приложений в Вашей работе. Стоит отметить, что у нас каждый из Вас может не лишь скачать новые программы, но и, естественно, скачать браузеры Mozilla Firefox.
Но, все конечно же хорошо, если бы не некоторый нюанс. После перехода на иной выпуск Firefox, большинство расширений, к которым Вы давно привыкли, оказываются полностью несовместимыми с новенькой версией программы. В данной ситуации, при попытке установки необходимого расширения, система пользователю выдает сообщение о несовместимости расширения с этой версией браузера. В принципе, победить данную проблему не так уж и сложно, так как обычным способом реально обойти ограничение совместимостей дополнений. В итоге проблема с несовместимыми расширениями уйдет насовсем.
Для начала стоит предупредить, что сама эффективность такого метода равна примерно 95 процентов. Есть расширения, которые реально могут являться несовместимыми с Вашим выпуском программы и тут, как говорится, ничего не сделаешь. Но, в принципе, вероятность того, что Вы скачаете именно такое несовместимое расширение, - невелика.
Настройка браузера в работе при принудительной совместимости.
1. Заходим в скрытие настройки. Для этого, в адресной строке набираем: "about:config". При этом внимательно читаем само предупреждение, которое появляется в открытой вкладке. Обязательно соглашаемся с ним.
2. Создаем параметр под названием "extensions.checkCompatibility", отвечающий за проверку самой совместимости расширений. Жмем правую кнопочку мышки и переходим «Создать» - «Логическое». В появившемся окошке вводим название "extensions.checkCompatibility.". Затем после точки в этом названии вписываем номер выпуска Firefox. К примеру, параметр extensions.checkCompatibility.5.0 и так далее. Нажимаем «ОК». Таким образом, вполне просто можно отключить проверку самой совместимости расширений.
3. Следующий этап – отключение проверки безопасности самих обновлений. Точно также как и в предыдущем пункте создаем данный логический параметр,- параметр extensions.checkUpdateSecurity. Само значение необходимо выставить в "false".
И все. Можно использовать любое расширение, не думая о том, что нужно искать совместимое дополнение для Вашего выпуска Mozilla Firefox.
Mozilla Firefox - для Windows
Информация
Наверх